Greenstuff and normalstuff

Info on parts and accessories for the Mégane II, what to use and where to buy them.

Moderators: q292u, Ray, AndyAdmin, Stranger

When I brake I use.....

The OEM pads - installed when car was purchased - they Squeak
12
55%
The OEM pads - installed when car was purchased - they DON'T Squeak
1
5%
Other standard pads - they squeak
5
23%
Other standard pads - they don't squeak
0
No votes
Greenstuff - they squeak
3
14%
greenstuff - they don't squeak
1
5%
Red stuff - they squeak
0
No votes
Red stuff they don't squeak
0
No votes
I don't know!
0
No votes
 
Total votes: 22

sporttourer
Pass Plus
Posts: 177
Joined: Sat Aug 06, 2005 10:55 am

Greenstuff and normalstuff

Postby sporttourer » Thu Mar 22, 2007 5:32 pm

So how good is this greenstuff then, expensive to do both axles at once. But please give me your experiences!
---------------------
All information and/or advice given is in good faith and any action taken by the reader is done so at their own risk.

User avatar
Old Bill
Learner Driver
Posts: 83
Joined: Mon Jan 09, 2006 10:39 am
Currently Drives:: LY R26 Lux No 2875
Location: Warrington / Brecon (depends if I am working)

Postby Old Bill » Fri Mar 23, 2007 6:33 pm

I use the OEM pads, however, they don't squeak. There wasn't an option for that though so I just ticked the OEM Squeaks.

sporttourer
Pass Plus
Posts: 177
Joined: Sat Aug 06, 2005 10:55 am

Postby sporttourer » Fri Mar 23, 2007 6:48 pm

am sure i added it but hey its not there.

I can't edit the poll now that votes are in so just mention if your OEMS squeak or not. [/b]
---------------------

All information and/or advice given is in good faith and any action taken by the reader is done so at their own risk.

User avatar
IainMW
F1 Driver
Posts: 1549
Joined: Thu Oct 20, 2005 5:48 pm
Currently Drives:: Laguna III 2.0dCi 150 Dynamique Hatchback. Pearl Black, Panoramic Sunroof, Front & Rear Proximity Sensors, 17" Spider Alloys (with B****y expensive tyres on!)
Location: In the Foot Hills of the Valley of the Pie Eaters!

Postby IainMW » Sun Mar 25, 2007 11:44 am

Mine are the original pads, and only squeak when going backwards? :? :hm
So I selected the top one.
Make improvements, not excuses!
Laguna III 2.0dCi 150 Dynamique Hatch. Pearl Black, Panoramic Sunroof, Front & Rear Proximity Sensors, 17" Spider Alloys (with B****y expensive tyres fitted!)

User avatar
Ray
Site Admin
Posts: 3844
Joined: Mon Mar 21, 2005 1:11 am
Currently Drives:: 2005 Megane Privilege - Now Sold
Location: Hong Kong
Contact:

Postby Ray » Sun Mar 25, 2007 1:18 pm

sporttourer wrote: I can't edit the poll now that votes are in so just mention if your OEMS squeak or not.

I have used my magical powers and presto! There is a new option for those on OEM pads that DON'T Squeak! :shock:
Image

sporttourer
Pass Plus
Posts: 177
Joined: Sat Aug 06, 2005 10:55 am

Postby sporttourer » Sun Mar 25, 2007 3:24 pm

I want to be like him


:wor


thanks Ray 8)
---------------------

All information and/or advice given is in good faith and any action taken by the reader is done so at their own risk.

Moto
Posts: 8
Joined: Sun Feb 25, 2007 9:23 am
Location: oxford

Postby Moto » Thu Mar 29, 2007 5:45 am

Hi everybody.

I have just bought a Megane 225 and the brakes howl when I apply them whilst reversing . I have been reading this forum and it looks a pretty common problem. Any of you guys had a result from Renault in resolving this ?


Chris.

User avatar
Old Bill
Learner Driver
Posts: 83
Joined: Mon Jan 09, 2006 10:39 am
Currently Drives:: LY R26 Lux No 2875
Location: Warrington / Brecon (depends if I am working)

Postby Old Bill » Thu Mar 29, 2007 4:48 pm

Hang on, that makes my vote wrong.... can you change that too Ray??

Second thoughts leave it, it will probably develop squeaks sooner or later, even with the Renault 'fix'.

meganeboy
Pass Plus
Posts: 231
Joined: Tue Jul 12, 2005 8:17 pm

Postby meganeboy » Thu Mar 29, 2007 6:18 pm

My OEMs DONT Squeak!!! They never did from new!! Mine is an 05 Saloon
Meg2 Sedan, 1.6VVT, Hologram Grey, Climate Control, 16" alloys, Pioneer DEH-P6900IB, JBL GTO527, Pioneer TS-Q131-C, Osram Silverstar, NGK Iridium plugs

L77
Pass Plus
Posts: 227
Joined: Sun Nov 20, 2005 10:23 pm
Location: In my bubble in the 225!

Postby L77 » Thu Mar 29, 2007 6:54 pm

Put Greenstuff pads on about 6 weeks ago, deary deary worst mistake I have made since I have had my meggie :oops: :oops: :oops:

Its embarrassing drawing up to my house I may as well blast my horn just to let everyone know Im home that would be more discreet!!!
____________
________
____

L77


Return to “Parts and Accessories”

Who is online

Users browsing this forum: No registered users and 4 guests