Engine Problem?

Information and general chat about the Megane II CC.

Moderators: q292u, Ray, AndyAdmin, Stranger

Andy1970
Posts: 15
Joined: Fri Apr 28, 2017 1:23 pm
Currently Drives:: Renault Megane Privilege Convertible 1.6 VVT

Engine Problem?

Postby Andy1970 » Mon Sep 25, 2017 7:19 am

Hi guys.

The other day I was out for a drive in my 1.6 and all was well. The usual pleasant smooth drive. Until...

I stopped off at a friend's house to pick them up. I sat outside for a few minutes with the engine running until they came out. There was a small judder from the engine but I thought nothing of it. My friend came out, got in the car and we set off on the two minute journey to my place. I noticed the drive was not so smooth and a bit sluggish. I also noticed that the engine warning light was flashing on and off. Quite worrying.

Anyhow, the next day I went out to the car and it started first time as usual. No engine warning light until the engine had been running for a few minutes. I pressed the accelerator pedal and each time there was a judder before the revs went up. Intermittently the engine light stopped flashing for a short while then started again. I've checked the oil, coolant, power steering fluid etc and all is well.

I'm wondering if it could be the spark plugs or coils? Maybe even the petrol? I put £20 worth in at a station I've not used before the day prior to the problem starting.

Sat scratching my head here and feeling a bit worried. All advice will be greatly appreciated.

Thanks in advance.

Andy1970
Posts: 15
Joined: Fri Apr 28, 2017 1:23 pm
Currently Drives:: Renault Megane Privilege Convertible 1.6 VVT

Re: Engine Problem?

Postby Andy1970 » Fri Oct 27, 2017 10:19 am

Thanks for all your help and advice guys (sarcasm).

I traced the problem to an ignition coil, so changed them all and the plugs while in there.

Again, thanks for all your help...

NeilS
Passed Theory
Posts: 32
Joined: Sat Jul 11, 2015 8:11 am
Currently Drives:: Megane cc 1.9dCi Privelage auto
Location: South Wales

Re: Engine Problem?

Postby NeilS » Fri Oct 27, 2017 11:27 am

Only just seen this. Had a very similar problem on my old Galaxy, and managed to find that one of the coils had gone. I replaced both and it was fine after.
(Insert something creative/witty/imaginative here _ _ _ _ _ _ _ _ _ _ )

alex3025
Passed Theory
Posts: 41
Joined: Sat Apr 08, 2017 9:15 pm
Currently Drives:: Renault Megan cc 1.6 black with black leather
Location: Torrox near Málaga

Re: Engine Problem?

Postby alex3025 » Fri Nov 03, 2017 1:40 pm

Believe it or not I was about to ask the same question as 1st post as mine started doing it yesterday night

ChrisM
Advanced Driver
Posts: 677
Joined: Wed Apr 15, 2009 9:57 am
Currently Drives:: Megane CC 1.9Dci and a Pugeot 307 cc 2.0 HDi sport.
Location: Wales
Contact:

Re: Engine Problem?

Postby ChrisM » Sun Nov 05, 2017 11:56 pm

"Thanks for all your help and advice guys (sarcasm)."

Well to be brutally honest there is only a very small handful of people on here that actually repair their own cc, most get taken to garages, you would be better off posting tec questions in the hatch forum probably stand a better chance of an answer.
A cc is 80% a hatch engine, suspension, brakes, gearbox wings, bonnet front bumper and a good part of the electrics yet most people are either nervous to try a repair or think they have something special.
For example I needed a handbrake 8 years ago so I looked on eBay £45 plus post for a cc one so I started saving but what's the difference with a hatch one so I searched again and found a hatch one £20 including post wow what a difference later I got another as they are a weak spot for£15 including post from an estate, no difference at all same with rear pads Delphi where for cc £25 for hatch £15 same pads rear caliper cc £85 hatch £45 and my best purchase a driver seat eBay and find a part where all over £120 for a cc yet I bought a seat for £60 including delivery in the same colour beige leather from a 3 door hatch same seat fitted straight in even had the anti submarine air bag makes me wonder how many on here get charged more to look at their cc in these garages?
I have just changed mine after 9 years for a mk3 cc and good ole eBay seller are still at it it need front brakes mintex discs £62 but same seller has hatch discs for £51 but I can't get a part number off him for the discs personally I think they are the same disc. But as said if you want a mechanical answer post in the hatch forum I think you would stand a better chance for a proper reply.

alex3025
Passed Theory
Posts: 41
Joined: Sat Apr 08, 2017 9:15 pm
Currently Drives:: Renault Megan cc 1.6 black with black leather
Location: Torrox near Málaga

Re: Engine Problem?

Postby alex3025 » Mon Nov 06, 2017 2:57 pm

Just changed the pencil coils £48 from eBay seems to be working fine now

Andy1970
Posts: 15
Joined: Fri Apr 28, 2017 1:23 pm
Currently Drives:: Renault Megane Privilege Convertible 1.6 VVT

Re: Engine Problem?

Postby Andy1970 » Fri Nov 17, 2017 12:53 am

alex3025 wrote:Just changed the pencil coils £48 from eBay seems to be working fine now


I'm certain I paid much less than that for mine off eBay (to fit the 1.6 16V). Anyway, glad to hear you got the problem sorted.

Does anyone know if it's an MOT fail with the "roof mechanism fault" message popping up all the time? Although the roof works perfectly well with the engine off. Bloody annoying issue with the bleeping to contend with.


Return to “Megane CC”

Who is online

Users browsing this forum: Google [Bot] and 5 guests