NEWBY "CHECK ANTI-POLLUTION" Fault

The section for all Megane III talk.

Moderators: q292u, Ray, AndyAdmin, Stranger

Gazj05
Posts: 5
Joined: Sun Jun 02, 2019 6:54 pm
Currently Drives:: 2012 Renault Megane

NEWBY "CHECK ANTI-POLLUTION" Fault

Postby Gazj05 » Sun Jun 02, 2019 7:08 pm

Evening,
Ive got a 62 plate Megane 1.5 dci
I have an intermittent "check anti-pollution" error pop up on the car. It comes on as soon as I start the car and once its on, it stays. I might then start the car the following day and its cleared.
If the fault is not there I also get intermittent faults pop up for just one or two seconds. Strangely the fault message is dependant on the cruise/limiter switch.
If the switch is at
Off - "Check Ignition System"
Cruise Ctrl - "Check Cruise Control System"
Speed Limiter - "Check Speed Limiter System"

Ive had a diagnostic computer on with the following fault codes:-
P0226, P0638, P1525, P0380, P1480, P148C

The glow plugs have been changed but the fault is the same.

Any help would be appreciated as im starting to debate driving the car off a bridge.

copas
Posts: 16
Joined: Wed Nov 17, 2010 1:08 pm
Currently Drives:: Megane coupe MK3

Re: NEWBY "CHECK ANTI-POLLUTION" Fault

Postby copas » Wed Jun 05, 2019 11:38 am

Hi,

Anti pollution message is problematic on all cars so please don't send it off the bridge just yet; the coupe really is good if you can live with a few French quirks. Sounds like you have done a lot of investigating so might no be of much help but;

try living with; this message can go after several weeks never to return for another year

unwire battery lead and leave for a few hours to completely discharge the car electrics; I think the engine management system on some cars sets some reference level on reboot;this worked for me on a citreon

the unusual link to cruise control seems bizarre but I had exactly the same on the citreon. every time I put cruise control on the service light came on a little later. Only made the link after reading other people had this on a forum. Turned out it was a software glitch on early cars so maybe a software issue - see if there a update for this year car

have an MOT - lots of useful readings on emissions may give you reassurance the car is running ok and its just a false alarm message

Gazj05
Posts: 5
Joined: Sun Jun 02, 2019 6:54 pm
Currently Drives:: 2012 Renault Megane

Re: NEWBY "CHECK ANTI-POLLUTION" Fault

Postby Gazj05 » Wed Jun 05, 2019 9:11 pm

Thanks for the reply. I've removed the battery and will refit first thing in the morning. Hopefully this fixes the fault and then my only issue will be recoding the radio.

Update to come...

Regards
Gaz

Gazj05
Posts: 5
Joined: Sun Jun 02, 2019 6:54 pm
Currently Drives:: 2012 Renault Megane

Re: NEWBY "CHECK ANTI-POLLUTION" Fault

Postby Gazj05 » Fri Jun 07, 2019 12:41 pm

Reconnected the battery with no luck.

I removed the EGR Valve which was covered it deposits and cleaned it up.... which has also made no difference....

Could be a costly trip to the garage.

munz
Posts: 1
Joined: Sat Jun 08, 2019 5:41 pm
Currently Drives:: megane gt line 1.6

Re: NEWBY "CHECK ANTI-POLLUTION" Fault

Postby munz » Sat Jun 08, 2019 5:53 pm

hi,
take a look at this video, it looks be be the symptoms you are getting
regards

https://www.youtube.com/watch?v=PLfHjqGj9Oc

Chrali
Posts: 15
Joined: Tue Jan 03, 2017 10:04 pm
Currently Drives:: 2012 Renault Megane 1.5 DCI Coupe

Re: NEWBY "CHECK ANTI-POLLUTION" Fault

Postby Chrali » Sun Jul 07, 2019 10:42 pm

My 1.5 dci thew a pollution fault but I kept driving it anyway, and the cruise control wouldn't stay on. I eventually was without turbo which made for interesting driving. Turned out to be 2 small rubber pipes that go to the DPF pressure sensor. £20 for parts £200 for labour :( still it fixed the car.
When I picked up my car the mechanic said they'd had another Renault in with the same fault, so I'd imagine every DPF car will get this at some point.
Image

Encourage alternative fuels, use all the petrol and diesel!

Gazj05
Posts: 5
Joined: Sun Jun 02, 2019 6:54 pm
Currently Drives:: 2012 Renault Megane

Re: NEWBY "CHECK ANTI-POLLUTION" Fault

Postby Gazj05 » Mon Jul 08, 2019 5:56 am

Thanks for the reply Chrali.
Was it the pipes on the sensor that the bloke is doing the voltage checks on in the above video.

I've had it in the garage and they think there is a valve stuck which controls the air/fuel mix.

It's going in next week but itll be worth me replacing them pipes beforehand if I can I guess.

Regards
Gaz


Return to “Megane III”

Who is online

Users browsing this forum: No registered users and 1 guest