Filter ???

The section for all Megane III talk.

Moderators: q292u, Ray, AndyAdmin, Stranger

jaff64
Just Passed
Posts: 108
Joined: Thu Jun 17, 2010 8:24 pm
Currently Drives:: 2009 Megane Privilege 4 door 1.5 dci
Location: Birmingham

Filter ???

Postby jaff64 » Tue May 07, 2019 8:28 pm

Hi, wondering if anyone can shed some light on this
Ordering a oil filter online, and it’s coming up as two different filters. One says Bypass valve opening 1.5 bar and the other 0.8 bar . My car is a Megane 1.5 dci Mk3, no DPF fitted..... Thanks

MrMeganeM3
Posts: 2
Joined: Wed Jun 05, 2019 6:31 pm
Currently Drives:: Megane Mk3 1.5 dci Tomtom

Re: Filter ???

Postby MrMeganeM3 » Wed Jun 05, 2019 7:24 pm

Hi
I had the same issue, mine is a 1.5dci with DPF but I noticed the difference to be either a filter for engines with 'stop start' function or non 'stop start', so I ordered with one with the bypass filter.
It must be something to do with not allowing the oil to drain back to the sump.
When I bought the car it had been serviced by Renault and they had fitted the smaller oil filter which is the wrong one for 'start stop' technology.
The correct filter was bigger than the one fitted.

jaff64
Just Passed
Posts: 108
Joined: Thu Jun 17, 2010 8:24 pm
Currently Drives:: 2009 Megane Privilege 4 door 1.5 dci
Location: Birmingham

Re: Filter ???

Postby jaff64 » Sun Jun 09, 2019 10:07 am

Thanks for the reply, very helpful :cool:


Return to “Megane III”

Who is online

Users browsing this forum: No registered users and 1 guest