Common Issues - Read this first

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

Paddy
F1 Driver
Posts: 1959
Joined: Sat Aug 23, 2008 5:22 pm
Currently Drives:: Megane Saloon 2.0 VVT Dynamique
Location: Belfast, Northern Ireland
Contact:

Re: Common Issues - Read this first

Postby Paddy » Tue Feb 15, 2011 7:31 pm

Nice post lad,

If you dont mind I'll clean the topic up and list as a sticky.

P

Binty
Posts: 1
Joined: Sat Jul 31, 2010 4:46 pm
Currently Drives:: Megane CC

Re: Common Issues - Read this first

Postby Binty » Mon Mar 14, 2011 11:21 pm

Dear Keenster,
I have had similar problems, it was on my previous Megane Mk1 convertable. really wierd stuf happened, like the window wipers would just come on, or an unrelated switch would cause the wimdow to lower etc.
The problem was water in the body control unit. A wire had been fitted through the bulkhead into this unit for a microwave alarm and not sealed properly allowing water to gain access. My local garage drained the unit, but it was stuffed!
They could get a new one for about £250 plus labour but only Renault could programme it to work as it has some security codes in it. As expected Renault were not helpful unless I was willing to re-mortgage :devil
The solution was found by sending the unit off to an electronic engineer somewhere in the west country. He removed the security chip from my unit, and placed it on a good second hand unit. When the new (used) unit was replaced, the car accepted it without re programming. There were no guarantees but this fix worked fine for me and is still going strong 4 years later, Total cost was about £150 including labour. Sorry I do not have the guys name, it will need some google work.
Good luck
Ian :life

Surfhunny
Posts: 19
Joined: Thu Jun 16, 2011 5:09 pm
Currently Drives:: Megane Coupe Cabriolet

Re: Common Issues - Read this first

Postby Surfhunny » Thu Jun 16, 2011 6:14 pm

I've just read this and had a quiet little laugh to myself. I love my Megane Coupe Cabriolet to bits but it bleeds me dry!! I've had almost every one of these common faluts relating to a petrol car. I've given up on my back windows, they've been disconnected now to prevent them motoring down and getting stuck, I'm riding out the dephaser rattle and just today my rotory switch has given up the ghost!! My mechanic is number 2 on my speed dial and knows my voice when I ring him. As much as I love my car as soon as the loan on it is paid off next year it's going!! I'm going to do a bit more research for my next car, instead of being swayed by good looks and smooth test drives. But having said that I do like the new Megane CC.......................

carlbentham
Posts: 23
Joined: Sun Dec 26, 2010 9:59 pm
Currently Drives:: megane 1.6 dynamique

Re: Common Issues - Read this first

Postby carlbentham » Sat Jul 23, 2011 8:20 am

R55VYS wrote:Just had the window reg break on me monday morning, after finding out its a £300 fix i set about trying to fix the problem for the mean time.

I think you should maybes add a quick fix to that link so that people dont need to use a binbag to cover the window.
Basically if you remove the reg from the white plastic triangle it frees up the cables so that the window can be pushed up and something placed beneth to keep the window up. its a fairly simple task once the door card is off and saves alot of chew, something renault wont tell you, then its a quick trip to the breakers and £40 for a reg as apposed to £200 plus labour from renault.


Be warned somtimes I think this is a scam on a criminal level had 2 of my 4 windows start going down and getting stuck strippped door down fired everything full of mps plus spray ( a trade version or wd40) and I mean
verything wiring connections controll module and reg put it back together re connected battery and they worked 2 windows on 2 occasions surley can't be coincedance

bainy51
Posts: 1
Joined: Mon Feb 06, 2012 11:38 pm
Currently Drives:: renault megane

Re: Common Issues - Read this first

Postby bainy51 » Thu Feb 16, 2012 10:38 am

1.6 Expression

I had a problem with my drivers side electric window. I lowered it to get a parking ticket then it refused to go back up. As if no power to it. Drove home with the window and rain pouring down... raging. Checked and changed fuse still nothing. Decided I was going to strip the door down started to take the door sound speaker off, removed plastic panel and speaker underneath. Had enough room to get my had down to the regulator and wiggled the wires. The window started working again.

I think connections are a big problem in meganes, my airbag light has came on a couple of times and again it is just a case of going under the front seats and wiggling the connecters and the light will go off on next engine start.

Recently one front side light blew. I changed both side lights just because I had bought two new bulbs in the pack. The one that had blew remained off and the other was fine. checked and swaped bulbs so it definately wasn't the bulb. I'm hoping its a fuse and not the wiring, although the engine fuse box is an apparent nightmare to get into.

My other sidelight has now gone out whether or not this is again the fuse or not I'm not sure. Anyway I'm going to attempt to get into the engine fuse box and check fuses if not, its probably lose connections at the front lights.

The thing that annoys me about these cars is the difficulty in fixing what you would think are simple problems. Changing bulbs fuses etc, this should be basic stuff.

Anyway i like a challenge.

carlbentham
Posts: 23
Joined: Sun Dec 26, 2010 9:59 pm
Currently Drives:: megane 1.6 dynamique

Re: Common Issues - Read this first

Postby carlbentham » Thu Mar 29, 2012 9:47 am

kenster wrote:Honestly i have to say never in my life have i come across such a confused automated car.

It winds down one of the windows on it's own weve had it disconnected for the moment - is this the regulator issue?
Most of the time the headlights are on even in midday sun,
Eats headlight bulbs ive changed about 4 now.
Indicators keep losing connection, a complete PIA how do i get to the connectors. I keep having to shove my hand up the back of the wheel arch to just reach and twiddle the back of the connector.
Wipers come on/off whenever they feel like it.
Try n wash the rear windscreen, washes the front.
Sometimes all 4 tyres have punctures and im going to die "STOP!!" Sometimes i only have one flat tyre.
When i run low on fuel (say below 30mile range) it refuses to give me any more detail like a petulant child!

And may i add 6th gear is like 4th gear in my A3!!!
Mechanically the car is ok, electrics are a complete funking disaster. Who the fck managed to design such an abortion without finding all these problems?


I did read somewhere else someone saying sell your Megane before it bankrupts you!!! I thought this car was great, its a smooth ride and handles well, although the 2.0 engine is massively dissapointing with zero low end torque and unhappy about revving to 6k.



This has to be the funnyest post I have ever read had me in stitches which make a lowers the blow of having what seems like an identical car lol the 1.6 int any better lol although it drinks like its a 2ltr


Return to “Problems / Questions”

Who is online

Users browsing this forum: No registered users and 20 guests