The Dashboard Display will not light up at all

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

spdury
Posts: 3
Joined: Fri Feb 08, 2008 9:42 am
Location: blackwood

The Dashboard Display will not light up at all

Postby spdury » Fri Feb 08, 2008 9:49 am

When starting my Renault Scenic Meaganne 1.9DCI none of the dashboard display will light up at all, no speedo, fuel, trip computer, clock or indicators. etc

Renault say it could be a cluster problem and would cost £400 to supply and fit. Any one else had this problem and can advise?

They Say its an Instrument Cluster
Cheers
Steve

User avatar
walibe
Pass Plus
Posts: 174
Joined: Sat Dec 16, 2006 12:12 pm
Contact:

Postby walibe » Fri Feb 08, 2008 7:10 pm

Which phase of Scenic? or a year will do.
Image

spdury
Posts: 3
Joined: Fri Feb 08, 2008 9:42 am
Location: blackwood

Postby spdury » Sun Feb 10, 2008 8:14 pm

54 plate new shap meganne Dynamic
Cheers

Steve

User avatar
BurntCarcus
Learner Driver
Posts: 78
Joined: Sat Dec 08, 2007 3:39 pm
Currently Drives:: Grand Scenic 2008 1.9Dci (130)
Location: Norn iron
Contact:

Postby BurntCarcus » Mon Feb 11, 2008 8:31 am

silly question but have you checked the fusses, or have you had the dash off for anything? Changed the stereo recently?
Back from Zafira hell....... Good to be home. Number 3 scenic bought and "im lovin it"

jlindridge
Posts: 3
Joined: Sun Feb 17, 2008 6:51 pm

Postby jlindridge » Sun Feb 17, 2008 6:55 pm

This fault happened on my megane today,
Did you get your's sorted yet - if so, any tips?

Cheers

catherine c
Posts: 11
Joined: Mon Feb 18, 2008 5:41 pm
Location: Berkshire

Postby catherine c » Mon Feb 18, 2008 5:44 pm

My Megane (dci 1.9 06 plate) does exactly the same thing, but not every time. I usually employ the IT favourite of turn it off and turn it back on again. That seems to do the trick.
Catherine

jlindridge
Posts: 3
Joined: Sun Feb 17, 2008 6:51 pm

Postby jlindridge » Mon Feb 18, 2008 6:00 pm

Hi,

Sadly that's not worked for me, have tried turning it off/on and leaving it for periods - all with no effect.

I've got it booked in at the local garage on thursday - I refuse to take it to renault so they can random replace stuff until they find the bit that's broken!

spdury
Posts: 3
Joined: Fri Feb 08, 2008 9:42 am
Location: blackwood

Postby spdury » Wed Feb 20, 2008 7:59 am

Yes got mine sorted at Renault, the Part was £390 then labour on top cost me £483.00 in total and only took them just over 1 hour to fix. I could have got a reconditioned part for £50 but they would not fit it.

Be aware though they cannot put the mileage back to what it was, it gets reset to 000000. i complained about this but there was nothing they could do, so i insisted they stamp the log book with the present mileage etc
Cheers

Steve

jlindridge
Posts: 3
Joined: Sun Feb 17, 2008 6:51 pm

Postby jlindridge » Thu Feb 21, 2008 11:58 am

Thanks for that Steve, I think it's out of order that they refused to fit a rconditioned part - it's your car after all!

I've just got mine back from my local garage:

They've cleaned up the dirty contacts at the back of the dash and now all is back in full working order, including mileage counter. Cost £100.

Thanks for the info,

Jaqui

JacquesC
Posts: 6
Joined: Sat Jan 19, 2008 11:31 am

Re: The Dashboard Display will not light up at all

Postby JacquesC » Mon Jan 05, 2009 1:20 pm

I get this intermittently on my Megane (07 plate 1.5 DCi 105hp). The time-honored helpdesk technique (switch off and switch on again) fixes it. If it happens again I'll take it to the dealers.

"sans illumier, Rodney".... as they say in Peckham....
Liberté, égalité, fraternité

cyril1946
Posts: 3
Joined: Mon Jan 19, 2009 1:13 pm
Currently Drives:: Renault Scenic Dynamique 1.9 dci
Location: yorkshire
Contact:

Re: instrument panel

Postby cyril1946 » Mon Jan 19, 2009 1:42 pm

walibe wrote:Which phase of Scenic? or a year will do.

my 53 plate scenic is doing the same except it comes on after a good run, but all my display has been reset.
My mileage reads 13000 mire than before. help. :cry

User avatar
renault37
Posts: 4
Joined: Mon Mar 26, 2012 3:18 pm
Currently Drives:: Megane 1.9 dci privilege
Location: Burton

Re: The Dashboard Display will not light up at all

Postby renault37 » Tue May 08, 2012 6:53 am

Ino this is an old thread but the only one i can find!!!

My 2004 dci megane's milage display has started acting up this morning on my way the work it had gone black and didnt show a thing so when i got to work i turned the car on and off and it came back on showing
Press the clutch or brake to start. It then went to the oil level as noral nd it came to the message screen saying auto lights deactivated and usual. But if i press the stalk it will not move and just stays on the message

Larryb
Posts: 3
Joined: Wed Jul 03, 2019 6:46 am
Currently Drives:: RENAULT MEGANE II 19DCI 2006

Re: The Dashboard Display will not light up at all

Postby Larryb » Wed Jul 03, 2019 7:03 am

Good day, I have a problem with my Renault Megane 1.9dci not starting up. When I insert the card and start all other lights are showing up, but the engine light does not show up. The engine is turning over nicely, does not end up staring at all.
Could you please assist!


Return to “Problems / Questions”

Who is online

Users browsing this forum: No registered users and 14 guests