I hate electrical problems

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

MarkSin
Posts: 22
Joined: Sat Jun 03, 2017 4:11 pm
Currently Drives:: 2005 Renault Megane II Estate

I hate electrical problems

Postby MarkSin » Mon Aug 10, 2020 5:13 pm

I have had my car now for about 4 years. In all that time the air conditioner and rear window demist haven't worked. I haven't tried fixing them because I live in Norway (mostly) and we only have one hot day a year.
However, the other day I realised that both the air conditioner and demist lights work when the switches are pressed on. This got me thinking that maybe there was a simple solution to why both lights work but the intended function doesn't work.
Does anyone have any idea on what the problem might be, a simple earth or fuse maybe?
I am currently living in a city and my car lives on the street so any work I have to do on it happens there.
I know it's wishful thinking that it might be a simple fix but it does seem a bit of a coincidence that both switches that share a common fixture could have the same problem.
Please let me know if anyone has any ideas.
Cheers
Mark
BTW my car is a 2005 Megane II Estate

DougM
Learner Driver
Posts: 68
Joined: Wed May 29, 2019 8:58 pm
Currently Drives:: Megane 2 1.6

Re: I hate electrical problems

Postby DougM » Tue Aug 11, 2020 6:20 pm

There is a 30A fuse under the bonnet for the heated window and a 10A for the compressor clutch. The aircon could be a multitude of issues. I would have it regassed first to be honest. The window is probably a broken element or duff connection to it.


Return to “Problems / Questions”

Who is online

Users browsing this forum: No registered users and 46 guests