Left hand side indicators not working.

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

Paddins
Posts: 2
Joined: Sat May 02, 2020 9:08 am
Currently Drives:: 2012 Renault Megane Sports Tourer

Left hand side indicators not working.

Postby Paddins » Sat May 02, 2020 9:30 am

Hi Folks,
I drive a 2012 Megane Sports Tourer 1.5-litre dCi. The LHS indicators have stopped working. I have checked both the fuse and the bulbs and they are all OK. When the indicator stick is turned down for a left turn, the light occasionally, not always, flicks on for one flash - then nothing. Does anybody have any idea how to deal with this problem? I would be very grateful if someone could suggest a solution.
Thank you.

alanf
Learner Driver
Posts: 64
Joined: Fri Apr 15, 2016 8:52 am

Re: Left hand side indicators not working.

Postby alanf » Sun May 03, 2020 11:31 am

Could be a bad earth, or dirt on the contacts on the stalk, I had this problem on a Vauxhall and all it needed was contact cleaner spray on stalk contacts.

Paddins
Posts: 2
Joined: Sat May 02, 2020 9:08 am
Currently Drives:: 2012 Renault Megane Sports Tourer

Re: Left hand side indicators not working.

Postby Paddins » Mon May 04, 2020 9:43 am

Thank you, Alanf,
I shall try that when I can get a motor factors open to purchase some. Is there a brand name you can suggest?


Return to “Problems / Questions”

Who is online

Users browsing this forum: No registered users and 56 guests