clutch is not returning

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

guardiandown
Posts: 1
Joined: Mon Sep 16, 2019 10:50 am
Currently Drives:: 2006 MEGANE DYNAMIQUE DCI 106

clutch is not returning

Postby guardiandown » Mon Sep 16, 2019 10:59 am

the other day my clutch didnt return, i mangaed to raise it back up with my foot, ive done some research and it says it maybe
the master or slave valve, does anyone have any help or experience with this? is it common? i just put my megane through its mot, got new wishbones, track-ends,etc it was driving like a dream but a day later this happens, any help would be greatly appreciated
many thanks

vanmanpaul83
Posts: 14
Joined: Sun Feb 24, 2019 7:45 pm
Currently Drives:: Renault Megane 2 1.6 16v Maxim

Re: clutch is not returning

Postby vanmanpaul83 » Mon Sep 16, 2019 4:39 pm

Sounds like the concentric slave cylinder has gone. The internal seals inside the cylinder can deteriorate as they age and the clutch pedal will not return. Unfortunately being concentric slave cylinder this is a complete unit with release bearing inside the gearbox meaning the gearbox has to be removed to replace. Usually find the slave cylinder fails more oftenly than the clutch master cylinder. Quite oftenly they go with a ping when they completely fail rendering the clutch inoperable. If this is the case given the nature of the work involved it is best practise to replace the clutch at the same time.


Return to “Problems / Questions”

Who is online

Users browsing this forum: No registered users and 13 guests