Complete engine shut down while driving

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

Mach3
Posts: 5
Joined: Thu Jun 27, 2019 10:51 am
Currently Drives:: Megan 1.9 estate

Complete engine shut down while driving

Postby Mach3 » Thu Jun 27, 2019 11:24 am

Hi. I've just joined the forum in the hope that somebody can shed some light on a problem I have with a thirteen year old Megane 1.9 diesel automatic estate car I bought last October. The car is in very good condition with full service history, the garage I use says its been very well maintained and every thing that needed to be done has been.
Soon after I bought it I noticed a flat spot with the accelerator, sometimes when pulling away there was no response but after several quick pumps it would respond. My garage changed the potentiometer which seemed to help, but didn't entirely stop the problem. While driving on a motorway I needed a quick burst of speed but when I pressed the accelerator there was nothing at all and the engine nearly stalled, thankfully it did pick up after pumping the pedal. My garage replaced the EGR with had some teeth missing on the quadrant gear which meant it sometimes didn't fully engage with the gears that operate the valve. When driving back from the garage the car completely stopped, thankfully I wasn't in traffic. The dash warning sign said select park and injector problem, the car did start but was undrivable. My garage recovered the car and the only fault they found was a faulty ABS sensor, which they replaced and its been okay for several weeks. Yesterday while in traffic and travelling around the 40MPH mark the engine completely cut out, the select park warning came on followed by the injector problem warning, fortunately nothing ran into me and I coasted into a layby. The RAC got the engine to run by blanking off the EGR and I got to my garage where its sitting waiting repair, the problem is we're no closer in knowing what the problem actually is. Any suggestions would be gratefully received as I'm scared to drive it again. Thanks

VroomVroomClonk
Just Passed
Posts: 111
Joined: Wed Oct 02, 2013 8:37 pm
Currently Drives:: Megane 1.9 DCi CC 2004
Location: Suffolk

Re: Complete engine shut down while driving

Postby VroomVroomClonk » Sat Jun 29, 2019 7:42 am

Your original problem -
Mach3 wrote: I noticed a flat spot with the accelerator, sometimes when pulling away there was no response but after several quick pumps it would respond.

sounds like this problem that several of us have had over the years with a faulty brake pedal switch. Yes, I know, you are probably already thinking I'm mad, but please search the forum for other people who have used the same fix, and bizarre though it seems it really is the answer!

However, if the RAC have now got you running by blanking off the EGR, then that sounds like you now have a different problem as well. You really need to get the codes read using Renault Can Clip software as that shows a lot more information than most of the generic readers.

Mach3
Posts: 5
Joined: Thu Jun 27, 2019 10:51 am
Currently Drives:: Megan 1.9 estate

Re: Complete engine shut down while driving

Postby Mach3 » Sat Jun 29, 2019 10:41 am

Thanks for your input and no it doesn't surprise me at all, my wife had a Freelander and had a gearbox warning light come on, the main agents said she needed a complete new gearbox, which would have cost more than the car was worth, so she sold it very cheaply because of the warning light. the chap who bought it took it to an independent 4x4 garage who replaced a small sensor under the wheel arch, problem solved!!!!


Return to “Problems / Questions”

Who is online

Users browsing this forum: Bing [Bot] and 11 guests