'Check Injection' under acceleration

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

AndyAitch
Posts: 9
Joined: Wed Apr 11, 2018 5:31 am
Currently Drives:: Megane II CC Dynamique 1.5DCi

'Check Injection' under acceleration

Postby AndyAitch » Wed Apr 11, 2018 7:24 am

Hi, I'm a newbie so please be gentle...

I know the 'Check Injection' problem has been discussed at length on here but I can't find an answer to this one :

I have a Megane II CC 1.5DCi. The engine will be warmed up, I might have travelled 8 - 10 miles. If I'm accelerating hardish up a slope (my local bypass), the Spanner lights up and the 'Check Injection' message appears. I feel a little hesitation as it happens and then the car is OK... If I park up for a few minutes and then start again, the message has cleared and all's good again until next time. I'm thinking that this isn't a glow plug problem as it seems to happen at any time if I've got my foot down.
Any help would be greatly appreciated, I'm quickly falling in love with this car and I'd like to get this problem sorted then I'm not panicking every time it happens :)

Thanks all

grandadbobby
Advanced Driver
Posts: 499
Joined: Thu Feb 16, 2017 9:05 pm
Currently Drives:: megan dynamique estate 1.9dci

Re: 'Check Injection' under acceleration

Postby grandadbobby » Wed Apr 11, 2018 6:15 pm

Hi, and welcome to the forum.
No good guessing I'm afraid, you need to read any fault code stored to put you in the right direction.
Should there be no fault code stored then it's a fuel related problem, air in system, blocked fuel filter etc.
Many people have spent a fortune doing the guessing game.
It could be a very simple and cheap fix.
Good luck
Bob.


Return to “Problems / Questions”

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 19 guests