Megane Cc roof problem

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

Davemc
Posts: 14
Joined: Sat Apr 08, 2017 7:18 pm
Currently Drives:: 2004 megane cc

Megane Cc roof problem

Postby Davemc » Mon May 29, 2017 9:48 am

Just now I've a problem with my roof going down and wondering if you know how many position sensors there is.

The first common one on the windscreen is free and moving fine and when I had a computer on it (very early stages to the problems I've had don't have access to it now) it showed open close when pressing it with my finger so I know it was fine

What the roof is doing is the boot opens up unlocks from the windscreen and starts to lift.

The front of the roof gets to about half way say above start of rear seats and stops roof malfunction I can keep pressing the button on until it stops again all the way into the boot but the boot stays open. If I have someone put pressure on the boot and keep pressing the boot will go down but won't lock into position don't think it knows it's at it's final position to lock things up. The roof won't return I need to wait till the pump loses pressure lift the roof up manually to about half way again before I can use the button to close it again.

I'm starting to think it's the pump but it's one of the last things I really want to change. I fitted two solenoids to the pump I got from the scrap yard to no avail.

Original problem was someone fitted the wrong ecu to the car a type from the ones with the raised roll bars so I got the ecu codded to say it's the fixed type and now I'm left with this problem.

Able to shed any light on this? Maybe get back on a computer and reset position or once it's fully closed (gives the beep of indication it's finished) should it not now know it's position as all windows go up once closed. Also they all go down when starting the procedure the near rear window is working fine unlike some others on here who have that problem

And it's on a 2004 megane cc

Return to “Problems / Questions”

Who is online

Users browsing this forum: No registered users and 9 guests