Turbo just went bang!

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

DrGonzo
Posts: 1
Joined: Mon Apr 24, 2017 2:59 pm
Currently Drives:: 2006 Megane 1.5 Estate

Turbo just went bang!

Postby DrGonzo » Mon Apr 24, 2017 3:15 pm

Hi,

So doing the usual only join the forum when my car dies thing - not my finest moment. Maybe if it survives this I'll post something a little more helpful.

Anyway my 2006 MK 2 Facelift 1.5 dCi Dynamique has an issue... I went to pull away vigorously and there was a loud bang followed by the sound of pressure releasing. The car starts fine and is drivable, it now sounds like the exhaust isn't connected - this thing is loud! Slow acceleration and it hesitates badly over about 3.5k rpm and struggles on hills. I also can't hear the sound of the turbo spooling, although its hard to hear anything with the noise it now makes.

I'm guessing something popped off between the turbo and the exhaust, but until I can get hold of some tools I can't see down the back of the engine to check. Has anyone else had this issue, or know what may have happened? I'm borrowing tools from a friend this evening and I'm going to start stripping it down, starting with that big ole' intercooler pipe and hopefully get a better look. But any advice would be greatly appreciated.

It's a shame as I have only had the car about 6 months and it's been fantastic, might go for a post '08 one when cash is a little less tight.

craigyt
Just Passed
Posts: 131
Joined: Mon Jul 22, 2013 10:42 pm

Re: Turbo just went bang!

Postby craigyt » Mon Apr 24, 2017 5:07 pm

Sounds like the egr pipe has broken pre turbo or aturbo gasket has failed. Unless theres blue smoke out the exhaust the turbo will be fine.

Try not to drive it 'on boost' or you will overspin the turbo n kill it that way.

With the engine running have a feel down the back and see if you can feel hot air blowing. Or fet someone to rev it while your looking down the back


Return to “Problems / Questions”

Who is online

Users browsing this forum: No registered users and 12 guests