1.9 dci 130bhp injector coding?

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

Steviboi
Posts: 9
Joined: Sun Jan 29, 2017 10:56 am
Currently Drives:: 2007 Megane 2 1.9 dcI.

1.9 dci 130bhp injector coding?

Postby Steviboi » Mon Mar 27, 2017 8:45 pm

Hi can anyone tell me in what order the injectors need to be coded in please? At the moment they are from belt 1234. But I have read it should be 4321. Previously to me closing them 1234 they was 1342, I think firing order. I'm getting limp mode under load mainly on inclines. And also a flashing spanner and stop light at high rpm. I have had it on code reader and got low rail pressure. Fuel pressure sensor code.... think it was p0069 or something like that. Anyway I've fitted a brand new fps and problems are still there. Any ideas?

Thanks fellas.

User avatar
MilosB
Advanced Driver
Posts: 257
Joined: Sat Nov 16, 2013 8:39 pm
Currently Drives:: R. Megane 2 1.9dci sport package

Re: 1.9 dci 130bhp injector coding?

Postby MilosB » Mon Mar 27, 2017 9:33 pm

1 is from flywheel
Renault Megane II 1.9dci sport p. 3dr. lowered on koni's,and exhausting through sebring

grandadbobby
Advanced Driver
Posts: 499
Joined: Thu Feb 16, 2017 9:05 pm
Currently Drives:: megan dynamique estate 1.9dci

Re: 1.9 dci 130bhp injector coding?

Postby grandadbobby » Tue Mar 28, 2017 12:18 am

Hi,
l know that on a dci Clio it's 1 2 3 4 from flywheel end for coding.
l reckon the Megane would be the same but you need to make sure.
As for the low rail pressure, l would check that air isn't entering the system and giving low readings. (quick release connectors failing),
lf it runs ok at lower revs l doubt it is the pump.
Good luck.
Bob

Steviboi
Posts: 9
Joined: Sun Jan 29, 2017 10:56 am
Currently Drives:: 2007 Megane 2 1.9 dcI.

Re: 1.9 dci 130bhp injector coding?

Postby Steviboi » Tue Mar 28, 2017 11:26 am

Hi thanks for the reply. Do you think the injectors been coded in the wrong order could cause my problems? I will check all the pipe work next but I can't see no obvious leaks from the pipe work there is however a leak from the top of the tank when I fill it up. I've ordered a new seal and cap so will get that fitted also. Thanks again fellas

User avatar
MilosB
Advanced Driver
Posts: 257
Joined: Sat Nov 16, 2013 8:39 pm
Currently Drives:: R. Megane 2 1.9dci sport package

Re: 1.9 dci 130bhp injector coding?

Postby MilosB » Tue Mar 28, 2017 1:19 pm

most of the lines prior to the high pressure pump are under vacuum, so a leak wont be noticeable, it would only suck air in.
one common "leak" is also that the Bosch fuel filter is just short and does not seal properly and lets air in.
Renault Megane II 1.9dci sport p. 3dr. lowered on koni's,and exhausting through sebring

Steviboi
Posts: 9
Joined: Sun Jan 29, 2017 10:56 am
Currently Drives:: 2007 Megane 2 1.9 dcI.

Re: 1.9 dci 130bhp injector coding?

Postby Steviboi » Tue Mar 28, 2017 5:44 pm

Right thanks For that. Coded injectors in the correct order today. Still same problem. I will check the oil filter tomorrow, what filter is recommended for this engine? Thanks.

User avatar
MilosB
Advanced Driver
Posts: 257
Joined: Sat Nov 16, 2013 8:39 pm
Currently Drives:: R. Megane 2 1.9dci sport package

Re: 1.9 dci 130bhp injector coding?

Postby MilosB » Tue Mar 28, 2017 6:35 pm

get your car to a mechanic.. to one who knows what he is doing.
there is no reason an oil filter would cause any of the described symptoms...
Renault Megane II 1.9dci sport p. 3dr. lowered on koni's,and exhausting through sebring

Steviboi
Posts: 9
Joined: Sun Jan 29, 2017 10:56 am
Currently Drives:: 2007 Megane 2 1.9 dcI.

Re: 1.9 dci 130bhp injector coding?

Postby Steviboi » Tue Mar 28, 2017 9:27 pm

I meant fuel filter.

User avatar
MilosB
Advanced Driver
Posts: 257
Joined: Sat Nov 16, 2013 8:39 pm
Currently Drives:: R. Megane 2 1.9dci sport package

Re: 1.9 dci 130bhp injector coding?

Postby MilosB » Tue Mar 28, 2017 9:32 pm

:grin
Renault Megane II 1.9dci sport p. 3dr. lowered on koni's,and exhausting through sebring

Steviboi
Posts: 9
Joined: Sun Jan 29, 2017 10:56 am
Currently Drives:: 2007 Megane 2 1.9 dcI.

Re: 1.9 dci 130bhp injector coding?

Postby Steviboi » Fri May 12, 2017 10:21 pm

So still having problems with this car. Anyway I have sorted the flashing spanner light at high rpm. This problem was a deteriorated rubber hose connecting to one of the dpf sensors. Noticed air in fuel pipes for the primer so replaced primer and all fuel lines to the pump, this seems to have stopped the air now. Also noticed a split in the plastic hose from throttle body to intercooler so have replaced this also. Altho the car does now pull a lot harder it still flashes up check injection and stop light and if in the motorway it will just kind if go in limp mode with no warning or lights!

User avatar
MilosB
Advanced Driver
Posts: 257
Joined: Sat Nov 16, 2013 8:39 pm
Currently Drives:: R. Megane 2 1.9dci sport package

Re: 1.9 dci 130bhp injector coding?

Postby MilosB » Fri May 12, 2017 11:03 pm

do you get any error codes stored on the ECU ?
PS, the broken pipe from the IC to the throttle body caused my turbo to descintegrate, as it wasn't worn out. the shaft failed
Renault Megane II 1.9dci sport p. 3dr. lowered on koni's,and exhausting through sebring


Return to “Problems / Questions”

Who is online

Users browsing this forum: No registered users and 13 guests