throttle problem

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

dcikev
Learner Driver
Posts: 91
Joined: Tue Oct 20, 2009 4:26 pm
Currently Drives:: 1.6vvt coupe, 1.9dci scenic

throttle problem

Postby dcikev » Wed Mar 05, 2014 6:26 pm

Megane 2004 1.6vvt
I have a problem with the throttle,when changing gear mostly from 1st to 2nd the throttle has a mind of it's own and can rev itself up to 3500rpm! also when idling the revs can stick around 1100rpm for around 20 seconds before dropping back to normal idle speed 800rpm.
The throttle housing is as clean as a whistle so it's not sticking.
Could it be the fly by wire system?
Cheers

john10001
Pass Plus
Posts: 205
Joined: Tue Dec 26, 2006 5:50 pm

Re: throttle problem

Postby john10001 » Wed Mar 05, 2014 7:13 pm

Some others in the forum will no doubt give their input which will be a lot more valuable than mine but I think it sounds more like a ignition coil problem and there is a misfire in one of the cylinders. If it's not that I would be thinking about dephaser or a sensor but I think ignition coil and misfire is most likely.

dcikev
Learner Driver
Posts: 91
Joined: Tue Oct 20, 2009 4:26 pm
Currently Drives:: 1.6vvt coupe, 1.9dci scenic

Re: throttle problem

Postby dcikev » Wed Mar 05, 2014 9:19 pm

cheers John,the dephaser was replaced a couple of years ago which I thought ruled that out,however the engine sometimes doesn't start first time.
have changed plugs,camshaft sensor and crankshaft sensor,maybe the coils need replacing.
Hopefully the dephaser doesn't need doing again!

davelowe
Driving Legend
Posts: 3136
Joined: Thu May 10, 2007 3:40 pm

Re: throttle problem

Postby davelowe » Fri Mar 07, 2014 6:38 pm

If you aren't getting any codes, the engine could be being commanded to rev as it does, in which case the throttle pedal sensor may be kaput.
Silver 08 plate 5dr 1.5dci Dynamique 106 Tech Run (re-mapped)

Red 03 plate 5dr 1.9 Dynamique dci120

Best advice for Megane owners: sell it before it bankrupts you!

dcikev
Learner Driver
Posts: 91
Joined: Tue Oct 20, 2009 4:26 pm
Currently Drives:: 1.6vvt coupe, 1.9dci scenic

Re: throttle problem

Postby dcikev » Sat Mar 08, 2014 3:43 pm

cheers,that was the only thing left to check.
Is there any way of checking the sensor on the pedal or is it a case of replacing the whole throttle pedal assembly?


Return to “Problems / Questions”

Who is online

Users browsing this forum: No registered users and 43 guests