CHECK INJECTION DISPLAYED!!!

Problem with your Megane? Can't find an answer? Workshop manuals and technical notes are in here.

Moderators: q292u, Ray, AndyAdmin, Stranger

Meggy-megane
Posts: 13
Joined: Fri May 06, 2011 12:27 pm
Currently Drives:: Renault Megane 1.6 16v

CHECK INJECTION DISPLAYED!!!

Postby Meggy-megane » Wed Sep 21, 2011 1:12 pm

Good day to you all, please help with the above, two days ago I was driving at night suddenly my 2003 Megane II stalled she refused to start and displayed the above message each time I`m trying to start, the engine is turning but would not idle. Is this a problem that I can fix myself, if it is a glow plug where is it situated and if the throttle valve needs to be clean where can I find it in the car. The reason for these questions is that I have found similar words used in the forums but they clearly do not answer my questions.

Paddy, Ray, Andy admin and any one else please help, your responses will be highly appreciated.

Thanks in advance :cool:

User avatar
Ray
Site Admin
Posts: 3844
Joined: Mon Mar 21, 2005 1:11 am
Currently Drives:: 2005 Megane Privilege - Now Sold
Location: Hong Kong
Contact:

Re: CHECK INJECTION DISPLAYED!!!

Postby Ray » Wed Sep 21, 2011 6:51 pm

glow plugs are in diesel cars only. i read from your profile, you have a 1.6 petrol.
search for dephaser or dephaser pulley
Image

Meggy-megane
Posts: 13
Joined: Fri May 06, 2011 12:27 pm
Currently Drives:: Renault Megane 1.6 16v

Re: CHECK INJECTION DISPLAYED!!!

Postby Meggy-megane » Fri Sep 23, 2011 7:13 am

Thanx Ray, you saved my day ;-)

User avatar
madwedge
Pass Plus
Posts: 160
Joined: Mon Aug 09, 2010 9:37 am
Currently Drives:: 2004 Renault Megane 2.0 litre 16v VVT Dynamique
Location: Southend-on-Sea

Re: CHECK INJECTION DISPLAYED!!!

Postby madwedge » Fri Sep 23, 2011 11:59 am

Have you fixed it then Meggy? I had this flash up a couple of months back while on the road and the car got really sluggish to drive. Like driving through treacle! lol

I pulled over and turned the engine off, waited 30 seconds and turn it on again with no problems. Not seen this issue since.

I have put some injection cleaner into the tank when filling up though on a couple of occasions, however I'd like to know what you did in case I get this again.

BTW I've got a 2.0 petrol.

Cheers
Currently Driving: 2004 Renault Mégane Dynamique 2.0 litre 16v VVT

Meggy-megane
Posts: 13
Joined: Fri May 06, 2011 12:27 pm
Currently Drives:: Renault Megane 1.6 16v

Re: CHECK INJECTION DISPLAYED!!!

Postby Meggy-megane » Fri Sep 23, 2011 12:36 pm

Madwedge, I have not fixed it yet I am still getting a few qoutations to see which would be the cheapest. My local dealer advised me to change the DEPHASER PULLEY and the CAMBELT, obviously this is what happens to Renaults when not serviced regulary.....

Take care

Meggy-megane
Posts: 13
Joined: Fri May 06, 2011 12:27 pm
Currently Drives:: Renault Megane 1.6 16v

STEERING LOCKED / NOT LOCKED

Postby Meggy-megane » Wed Oct 26, 2011 8:48 am

My Megane 1.6 16v have been parked since 23 September 2011 in order for me to acquire some funds for the replacement of the dephaser pulley and the cambelt hence it was showing "CHECK INJECTION" on display. It was normally turning the engine but would not start. Over the weekend I was planning to change all that was bought but suddenly the "STEERING LOCKED and STEERING NOT LOCKED" each time I tried to start and the word "SERVICE" is also displayed. I have tried to browse at most of the problems and answers on site but I do not get to an answer as how to fix the said problem. My baby is standing at a very awkward position as the mechanic is not able to replace the pulley cause we can not even push the car cause the steering is locked.

Please help :life God bless you all,

techsnap
Posts: 5
Joined: Mon Feb 21, 2011 11:09 am
Currently Drives:: Scenic II 1.6VVT Dynamique

Re: CHECK INJECTION DISPLAYED!!!

Postby techsnap » Wed Oct 26, 2011 1:33 pm

I saw the messages about steering locked/not locked when my battery was dying.

Is the battery flat or nearly flat?

Meggy-megane
Posts: 13
Joined: Fri May 06, 2011 12:27 pm
Currently Drives:: Renault Megane 1.6 16v

Re: CHECK INJECTION DISPLAYED!!!

Postby Meggy-megane » Fri Oct 28, 2011 7:08 am

The battery is 100%, I even used it on my other car and there were no starting problems drove around with it but still does the same on the Megane.


Return to “Problems / Questions”

Who is online

Users browsing this forum: Google [Bot] and 33 guests