Hey Folks, Im New!!!

Introduce yourself and let us know a bit about you and your car

Moderators: q292u, Ray, AndyAdmin, Stranger

User avatar
Nige
Advanced Driver
Posts: 277
Joined: Tue Jul 15, 2008 9:59 am
Currently Drives:: 03' Renaultsport Megane 1.4 16v...NO FAULTS HERE! :-D
Location: N.Ireland, Londonderry
Contact:

Hey Folks, Im New!!!

Postby Nige » Sat Aug 16, 2008 1:18 am

Hey folks, nice to meet you all. My Names Nigel, im from N.Ireland in the region of Londonderry in the Northwest. Looking forward to becoming a regular on here as im pretty Renault Mad all my driving days with 2 clios (Mk1 3 years) and MK2 10 Years)and now into the Megane II in a big way, lovely car.

Currently the proud owner of a Lovely 03' Megane 1.4 16v Extreame 3Dr Sport Hatch in Met Black. Which i sold my beloved 98' Phase 2 Clio for 1 1/2 months back. 10 Years with NO faults :grin

Have the Megane as said for 1 1/2 months with 40,500 on the clock and been spending the last Month in the garage completely stripping down and restoring the car back to fresh state so its moved nowhere since change of ownership to my hands. The car was firstly givin a complete Interior overhaul....its had the dash board completely removed, door cards and rear panels to be sound deadened with a lightweight material and all screws, bolts and clips individually reset to remove all creeks and noises. Roof lining all washed down and door cards steamed. The Driver seat was renewed with a new seat as the materials are known to be a little easy wore and steering wheel renewed. The interior is now complete and in showroom condition with all genuine replacements required as i hate a shabby car.

Exterior has seen a complete 5 step overhaul also which took me 2 weeks to complete. 1. T-Cut Removing all old polish and contaminants 2. Clayed with Meguires detailing kit 3. Meguires ScratchX removing all minor scrapes (none serious thankfully) 4. Meguires Deep Crystal Polish 5. Finally, finished with meguires lock and seal Tech 2 Car Wax (Paste). Its now sitting like a complete new car, 600 pounds spent on cleaning and replacement parts to date.

Next step is an engine/mechanical overhaul....upon recent evaluation i have heard that these cars suffer from some engine faults particularly the 1.6 models, but im taking no chances with the 1.4 unit as i know what renaults is like. (Quite common im made to believe) So im getting 4x new upgraded coil packs, new TDC sensor fitted and getting the Dephaser pulley changed when i get round to it. I also notice a small knocking noise on steering/ball joint passenger side on certain pot holes, so that will most likely be stripped apart also come time.

People think its a bit extreame but im the kind of fella that likes to get involved with a new car. The new megane being no exception to my family. I enjoy playing with faults but i think if you can fix it before it breaks then jobs a good one :-) so this forum will help me achieve many of my goals to having the perfect megane II. (I dont believe in buying new)

I look forward to getting to know you all! You all seem like a great bunch!! Some photos shall be making thier way soon to show you my progress :-)

Nigel
Image
03' Megane 1.4 16v 3Dr, N.Ireland

Jonault
Advanced Driver
Posts: 492
Joined: Fri Mar 23, 2007 7:52 pm
Location: Shrewsbury

Re: Hey Folks, Im New!!!

Postby Jonault » Mon Aug 18, 2008 10:47 am

Welcome to the club. You'll be pleased to find out that the 1.4 doesn't have VVT and therefore no dephaser pulley. The knocking from the suspension might be the strut top mount bearing which seems to be a common fault. :cool:
1.4 Hatch, Ottoman Blue, 55 Reg, Dynamique

User avatar
Stranger
Site Admin
Posts: 4224
Joined: Sat Mar 26, 2005 7:57 pm
Currently Drives:: BMW X1
Location: Lancashire

Re: Hey Folks, Im New!!!

Postby Stranger » Mon Aug 18, 2008 1:20 pm

Hello there Nigel and welcome along :tu
STOP DEVELOPMENT ON GREEN FIELD SITES! http://www.cpre.org.uk/

User avatar
A13XDT
Just Passed
Posts: 108
Joined: Fri Mar 28, 2008 2:20 pm
Currently Drives:: 54 Plate Megane Dci 86 Rush - Platinum Silver

Re: Hey Folks, Im New!!!

Postby A13XDT » Mon Aug 18, 2008 7:47 pm

How do mate.
Welcome Along
Image

User avatar
Nige
Advanced Driver
Posts: 277
Joined: Tue Jul 15, 2008 9:59 am
Currently Drives:: 03' Renaultsport Megane 1.4 16v...NO FAULTS HERE! :-D
Location: N.Ireland, Londonderry
Contact:

Re: Hey Folks, Im New!!!

Postby Nige » Tue Aug 19, 2008 11:33 pm

Jonault wrote:Welcome to the club. You'll be pleased to find out that the 1.4 doesn't have VVT and therefore no dephaser pulley. The knocking from the suspension might be the strut top mount bearing which seems to be a common fault. :cool:



Thanks folks :)

Didnt know that now, thankyou very much on filling me in on that! saves me alot of hassle. I just thought all meganes from early launch all suffered but thats definatly a load off my mind. Cheers for the heads up.

Will also get the strut bearing checked :) hopefully that wont be a hard job!....if the 1.4 megane suffers a struggle on starting (turning and turning but not firing up) its either TDC sensor or possible throttle body due cleaning? now that dephaser is out of the question? its just so im more aware what im dealing with as previous owner did mention this issue on my car.

Thanks again folks! :)
Image
03' Megane 1.4 16v 3Dr, N.Ireland


Return to “Introductions”

Who is online

Users browsing this forum: No registered users and 11 guests