Megane 1.6 16 v

Introduce yourself and let us know a bit about you and your car

Moderators: q292u, Ray, AndyAdmin, Stranger

Spud
Posts: 3
Joined: Wed Aug 10, 2016 6:20 pm
Currently Drives:: Megane 1. 1.6 16 v

Megane 1.6 16 v

Postby Spud » Wed Aug 10, 2016 6:39 pm

Hi this is my first post so please be gentle I recently purchased a 1.6 16v Megane 2001that as little power untill about 1200 revs it then clears and fly's on idle the engine is lumpy (gearstick moving) previous owners had four coils fitted this was six months ago their black top ( all four including fitting £130.00) I've replaced plugs cleaned tdc map sensor checked for air leaks when you disconnect each Injector the engine speed falls after 1200 revs the engine drives extremley well it just this holding back all four plugs on removal where light brown .any help would be greatly appreciated and I thank anyone in advance for their help ps engine warning light does not illuminate nor flash ( it does work)

User avatar
Stranger
Site Admin
Posts: 4214
Joined: Sat Mar 26, 2005 7:57 pm
Currently Drives:: BMW X1
Location: Lancashire

Re: Megane 1.6 16 v

Postby Stranger » Thu Aug 11, 2016 7:01 am

Hello Spud and welcome along :tu
STOP DEVELOPMENT ON GREEN FIELD SITES! http://www.cpre.org.uk/

Spud
Posts: 3
Joined: Wed Aug 10, 2016 6:20 pm
Currently Drives:: Megane 1. 1.6 16 v

Re: Megane 1.6 16 v

Postby Spud » Fri Aug 12, 2016 4:19 pm

Hi stranger thank you for the welcome regards


Return to “Introductions”

Who is online

Users browsing this forum: No registered users and 3 guests