Search found 48 matches

by speedy_glz
Sat Jun 05, 2010 8:01 pm
Forum: Problems / Questions
Topic: Instrument panel fault! HELP!!
Replies: 2
Views: 545

Re: Instrument panel fault! HELP!!

Ok, what is reseting is the "partial milleage", hope you understand me
by speedy_glz
Sat Jun 05, 2010 7:53 pm
Forum: Problems / Questions
Topic: Instrument panel fault! HELP!!
Replies: 2
Views: 545

Instrument panel fault! HELP!!

Hello everyone, now I have this issue at my Megane: the digital display at the instrument panel usually shows the engine milleage and the travel milleage (sorry if I miss with the proper translation, I dont know how it is called in english :hm ). Well the issue here is that the "travel milleage...
by speedy_glz
Sat May 15, 2010 7:28 pm
Forum: Problems / Questions
Topic: Why is my Megane 'Shuddering' when I brake
Replies: 24
Views: 3715

Re: Why is my Megane 'Shuddering' when I brake

What do you men with "warped" discs? Well, reading all the post of you guys, I found one saying that maybe be the braking force is uneven, and it looks like it is in my car. The front wheels always get more dirty by pads dust than the rear wheels. :banghead And the shuddering continues!! L...
by speedy_glz
Thu Apr 15, 2010 12:08 am
Forum: Problems / Questions
Topic: Why is my Megane 'Shuddering' when I brake
Replies: 24
Views: 3715

Re: Why is my Megane 'Shuddering' when I brake

Hello, I have the same problem as you. Mine started one year ago when I replaced the braking pads. That time I took it not with he dealer. There is a workshop specialized in tires & brakes and because I saw one megane there, I left it. After the pads change it started. I took the car with a stee...
by speedy_glz
Mon May 04, 2009 5:23 am
Forum: Everything Else
Topic: WHERE IS THE OBD PLUG??
Replies: 1
Views: 666

WHERE IS THE OBD PLUG??

Hello!!

Can somebody tell me please where to find the OBD plug in the car??

I know most of the cars has it on the panel mostly under the steering wheel

Thanks :grin !!!
by speedy_glz
Tue Apr 28, 2009 4:52 pm
Forum: Problems / Questions
Topic: PROBLEMS AFTER BRAKE SERVICE....
Replies: 5
Views: 993

Re: PROBLEMS AFTER BRAKE SERVICE....

Ok, lets summarise: Well, every fault happens suddenly, and as it comes, it goes, for my i guess that something is loose and with a bump this thing goes out of place and cause the problem, and with another bump, it comes back to place anr everything is ok now :conf Regarding brakes . Yes, my car has...
by speedy_glz
Sat Apr 25, 2009 8:30 pm
Forum: Problems / Questions
Topic: PROBLEMS AFTER BRAKE SERVICE....
Replies: 5
Views: 993

Re: PROBLEMS AFTER BRAKE SERVICE....

Well, I took my meg to a steering/suspension specialist, and the diagnosis was: "Your car is in really good conditions! All the mechanical components are good enough, bushes, bearings, suspension arms, everything its ok! just the steering has a little bit loose, but there is no problem!" W...
by speedy_glz
Thu Apr 23, 2009 7:13 pm
Forum: Problems / Questions
Topic: PROBLEMS AFTER BRAKE SERVICE....
Replies: 5
Views: 993

Re: PROBLEMS AFTER BRAKE SERVICE....

Thanks!!! Well, Im sending my meg to a steering/suspension specialist tomorrow, he checked it today and said that something weird is happening. What Im going to do is to check if something is loose on the steering arms and ask to check the bushes because I one of that kind of persons you say that dr...
by speedy_glz
Wed Apr 22, 2009 4:34 am
Forum: Problems / Questions
Topic: PROBLEMS AFTER BRAKE SERVICE....
Replies: 5
Views: 993

PROBLEMS AFTER BRAKE SERVICE....

Hello I have a 05 Megane with 2.0L petrol engine, 16 in wheels, mods: k&n air filter, xenon lights. My problems started after changing tha brake pads, like my car does not has more waranty, I took it to the first worshop I found they had the correct pads (Im from Chihuahua, Mexico, and still the...
by speedy_glz
Tue Feb 12, 2008 10:48 pm
Forum: Parts and Accessories
Topic: Megane II 1.6 manual response and acceleration
Replies: 49
Views: 12250

anybody using K&N air filter or any other sport airfilters? Im using an SPECTRE filter, (from U.S) and its working really good. I was planning to buy the K&N kit (57i series kit) but it was kind of expensive here, so I bought the filter, a couple and a hose and made a filter support, I save...
by speedy_glz
Tue Feb 05, 2008 11:54 pm
Forum: Parts and Accessories
Topic: whats the best spark plugs?
Replies: 2
Views: 1266

I had Denso Iridium and changed them for BOSCH IR Fusion (Iridium - 4 electrodes) and works great :cool:

Better acceleration and engine response :cool:
by speedy_glz
Tue Feb 05, 2008 8:54 pm
Forum: Parts and Accessories
Topic: Megane II 1.6 manual response and acceleration
Replies: 49
Views: 12250

I dont know if anyone here already said this, but another good option to improve the performance of your engine can be done by using iridium spark plugs and if you can find them with four electrodes, better. I had a DENSO iridium spark plug in my meg and change them for a BOSCH iridium with 4 electr...
by speedy_glz
Wed Jan 30, 2008 9:17 pm
Forum: Modifications
Topic: anyone remapped a 2.0 petrol meg?
Replies: 15
Views: 3163

wow!! thats great

and is there a box like that for a 2.0 16v Meg?? I only saw the one for the Turbo, does that one works with the "no turbo" too?
by speedy_glz
Wed Jan 30, 2008 9:03 pm
Forum: Modifications
Topic: anyone remapped a 2.0 petrol meg?
Replies: 15
Views: 3163

hey guys, I saw at K-Tec the "Power Box" they sell for the Megys. Exactly how this box works, you just plug it in and the box do the mod's, or you plug it in but still has to take your car to a dyno to do the mod's (remap)??
by speedy_glz
Wed Jan 30, 2008 8:49 pm
Forum: Parts and Accessories
Topic: Megane II 2.0 manual response and acceleration
Replies: 2
Views: 819

What is the Brake-in mode???

dos it has to be something about the ECU and the engine map??

Go to advanced search