My 1.9 diesel CC engine problem! (blue smoke+loss of power)

Informaion and general chat about the Megane II CC.

Moderators: Stranger, AndyAdmin, freelanderuk, Ray

My 1.9 diesel CC engine problem! (blue smoke+loss of power)

Postby ckier08 » Sat Mar 17, 2012 9:54 am

I was driving on the motorway yesterday morning and I noticed there was a noise coming from the engine that didn't sound right!(possibly sounded like the turbo wasn't 100%)
Then after 10mins I noticed blue smoke and lots of it coming from the back of my car and all over the motorway! Also my car went from
70mph to 60mph and wouldn't go faster!
I pulled in and got my dad to toe me home just incase!

Now he said if it was the turbo, there should have been black smoke everywhere not blue! He said it sounded like and looked like burning diesel!


Does anyone know hat the problem is and get back to me ASAP on it
Thanks!
ckier08
Learner Driver
 
Posts: 98
Joined: Wed Apr 06, 2011 1:56 pm
Location: Ireland

Re: My 1.9 diesel CC engine problem! (blue smoke+loss of pow

Postby jak01 » Sat Mar 17, 2012 5:16 pm

Blue smoke suggests it's burning oil, it could be the turbo, although they usually rev themselves to destruction if that's the case. Probably pistons/rings failed. Difficult to diagnose without seeing it. Sorry to say this but it sounds expensive. :(
Ford Mondeo, 1.6 vvt CC Privelege, 1973 MGB
jak01
Learner Driver
 
Posts: 58
Joined: Wed Oct 14, 2009 7:13 pm
Location: North Nott's

Re: My 1.9 diesel CC engine problem! (blue smoke+loss of pow

Postby davelowe » Sat Mar 17, 2012 11:05 pm

Visual and manual inspection of the turbo and its associated pipework for, respectively, play in the shaft; and oil in the air hoses.

Check the engine oil level and grade.

Perform a compression test.
Silver 08 plate 5dr 1.5dci Dynamique 106 Tech Run (re-mapped)

Red 03 plate 5dr 1.9 Dynamique dci120

Best advice for Megane owners: sell it before it bankrupts you!
davelowe
Driving Legend
 
Posts: 3140
Joined: Thu May 10, 2007 3:40 pm

Re: My 1.9 diesel CC engine problem! (blue smoke+loss of pow

Postby lee00069 » Sun Mar 25, 2012 11:50 am

jak01 wrote:Blue smoke suggests it's burning oil, it could be the turbo, although they usually rev themselves to destruction if that's the case. Probably pistons/rings failed. Difficult to diagnose without seeing it. Sorry to say this but it sounds expensive. :(


yea unfortunately jak01 is right. Just make sure to check the turbo and seals on turbo and if its not that then check piston rings.
I wouldnt suggest driving it like that since they can just start revving themselves "to destruction "if the intercooler gets full of oil.
If the car does rev itself you must put it in gear and hold the brake so that the engine stalls itself . That is the only way to stop it revving
Once you have diagnosed the problem just clean out the intercooler you will probably find it is full of oil. (you can do this with petrol or sending it off to a radiator repair place )
Image
lee00069
Learner Driver
 
Posts: 57
Joined: Fri Nov 20, 2009 5:27 pm

Re: My 1.9 diesel CC engine problem! (blue smoke+loss of pow

Postby ckier08 » Tue Apr 03, 2012 11:14 am

Thanks everyone for the replies! :)
I bought a Brand new turbo on eBay with a warranty and all!
Me and my father fitted the turbo together and it's 100%! :)
It was 380 euro altogether :D
ckier08
Learner Driver
 
Posts: 98
Joined: Wed Apr 06, 2011 1:56 pm
Location: Ireland


Return to Megane CC

Who is online

Users browsing this forum: No registered users and 4 guests