megane DCi 1.5 - will not start - Injection fault

Got a problem with your Megane II and can't find an answer in FAQ / Tips and tricks then post it here.

Moderators: Stranger, AndyAdmin, freelanderuk, Ray

megane DCi 1.5 - will not start - Injection fault

Postby the_toilet » Wed Jul 25, 2012 10:06 am

Hi Forum

this is my first post. i was using renaultforum but i thought I might be best trying a megane specific forum for my issue, as i am about to throw the car in the bin.

History:

I bought a megane II 1.5 DCi. i drive 100 miles a day to work and back, and found the car just perfect, brilliant car!. so economical it was untrue - 75-80mpg. However, i thought i had 100 miles left in the tank, the light came on, and it immediately ran out of diesel. i limped into the garage after running the starter motor a few times, and got the car filled up. ever since then, the car has trouble starting, and when under-load, the car displays injection-fault on the dash

i took the car to the mechanic, and he had it for 2 months, changed the pressure regulator, and the glow plugs (which were all broken somehow, even though it was starting before the fuel-run-out)

that mechanic had a heart attack, so i took the car to a new mechanic, he has now had it for 2 more months. he has changed the fuel pump, and the injectors, still it will not start.

points to note:

if i put jumper leads on her, i can get her started after 30 mins of turning her over.
if i do get her started, and then shut her of, she will start again very quick
if i park on a hill, and bump-start her, she will start!

so, anyone got any ideas?

are there any diesel and megane specialists in northern Ireland or the Republic for that matter?

chees
dan
the_toilet
 
Posts: 10
Joined: Thu Jun 28, 2012 8:12 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby tomalamix » Wed Jul 25, 2012 3:44 pm

it really sounds like a fuel feed problem which can occur with bad injector, bad fuel pump or air going inside the fuel feed pipes. do you prime the system before when you know it will take some time to start ..?
tomalamix
F1 Driver
 
Posts: 1726
Joined: Thu Jun 03, 2010 3:15 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby the_toilet » Wed Jul 25, 2012 6:09 pm

Hi there

i did not know you could prime the DCI as it is super high pressure pump. how woudl i prime it? i have definitely not tried it. i think you are right, i think there is a pessure leak somewhere along the line... it is still odd that it will eventually start

cheers
dan
the_toilet
 
Posts: 10
Joined: Thu Jun 28, 2012 8:12 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby davelowe » Wed Jul 25, 2012 10:06 pm

Dan, you prime the fuel system with a small black bulb. Look where the coolant reservoir is located under the bonnet. There is a piece of plastic trim in the way (remove the little black plastic 'plugs' that look like screws). This is slightly nearer the driver's seat than the reservoir. You will see the bulb and transparent fuel tubing (possibly hiding behind some aluminium AC pipework. Squeeze it while observing the tube for bubbles. If you see no fuel, there is leak somewhere - possibly pin sized.

The low and high pressure pumps are in the same assembly next to the engine.

I'm not surprised your first mechanic had a heart attack working on these damned cars!
Silver 08 plate 5dr 1.5dci Dynamique 106 Tech Run (re-mapped)

Red 03 plate 5dr 1.9 Dynamique dci120

Best advice for Megane owners: sell it before it bankrupts you!
davelowe
Driving Legend
 
Posts: 3140
Joined: Thu May 10, 2007 3:40 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby the_toilet » Mon Jul 30, 2012 3:44 pm

hi all

I just spent 2 hours wth the mechanic playing with the Megane... on a good note, the "injection fault" code has stopped coming up on the dash when you crank the engine... however, it will not fire.. i cranked it for about an hour, ran the battery down a good 10+ times, but no joy...

The current problem i think is an odd pressure build up on the diesel-return pipes. The pipe blew off injector 4 (or 1, no sure where they start from) a few times, and also the pipe where fuel return goes into the top of the fuel pump, before being sent back to the fuel filter... any ideas?

i am not sure if this new problem is just hiding the original problem, or if the injector fault is fixed, but we now have a new problem as a result of some of the work that was done?

going nuts here, and the mechanic has given up... says i shojld crap it, but that would be £3k down the drain (2 k for car, 1k to fix)

heeeeeeeelp.....
the_toilet
 
Posts: 10
Joined: Thu Jun 28, 2012 8:12 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby tomalamix » Mon Jul 30, 2012 9:30 pm

does the red dot on the dash goes off after the card is inserted and you try to crank the car?

if it goes off can you check the rail pressure with your friend mechanic using the EOBD cable + software? post the value

cheers
tomalamix
F1 Driver
 
Posts: 1726
Joined: Thu Jun 03, 2010 3:15 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby davelowe » Mon Jul 30, 2012 10:06 pm

the_toilet wrote:The current problem i think is an odd pressure build up on the diesel-return pipes. The pipe blew off injector 4 (or 1, no sure where they start from) a few times, and also the pipe where fuel return goes into the top of the fuel pump, before being sent back to the fuel filter... any ideas?


Jesus! That should not be happening - never ever. I think that the ECU is not commanding the rail pressure accurately, or something is blocked - but this is guesswork.

Can you not hook up a gauge and measure the actual pressure while cranking the engine?

Another idea would be to disconnect the return hose, and see when cranking that fuel is expelled (into a bucket)....
Silver 08 plate 5dr 1.5dci Dynamique 106 Tech Run (re-mapped)

Red 03 plate 5dr 1.9 Dynamique dci120

Best advice for Megane owners: sell it before it bankrupts you!
davelowe
Driving Legend
 
Posts: 3140
Joined: Thu May 10, 2007 3:40 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby the_toilet » Tue Jul 31, 2012 7:15 am

my plan today was to head back down with a multi-metre, and check if voltage is passing to the injector wiring when cranking, just in case they are just not firing, hence ALL the fuel is going back to the return pipes

i did disconnect the return pipe, ot see what was happening, and there is fuel spurting out of it when cranking, it goes out in spurts as you woudl expect as it cranks. i had thought initially that the pipes might be on backwards on the fuel filter, but i am not sure that is possible,, it just seemed odd that there was no fuel in the feed-line to the high pressure pump,m but seemed to be quite a lot in the return pipe. also, when i squeezed the priming bulb, the fuel seemed to move in the return pipe but not in the feed pipe. however, i disconnected the feeder pipe from the fuel pump, and the fuel did fly out when cranking...

i ned t try and get a presure checker hooked up to this think, but the mechanic does not have his own diagnostic equipment, so he has to bring someone in for 30 quid a shot :-(
the_toilet
 
Posts: 10
Joined: Thu Jun 28, 2012 8:12 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby the_toilet » Tue Jul 31, 2012 7:35 am

have any of you ever used one of them blue tooth diag readers for android or windows PC? one of these:

"ELM 327 Android Torque OBDII OBD2 Bluetooth Diagnostic Interface CAN BUS OBD"

i have a tablet, and if i plug on po these in, apparently it an read fuel pressure...
the_toilet
 
Posts: 10
Joined: Thu Jun 28, 2012 8:12 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby tomalamix » Tue Jul 31, 2012 10:16 pm

a multimeter will not catch the values on the injectors...its piezo, its too fast for read with a multimeter.

a good oscilloscope can do the trick but i think you can simple test them with the CLIP tool or other 3rd party software able to test the injectors actuation, you will simply ear a "bzzz" sound while testing one at the time...

and dave is right, the injectors are always closed returning all the fuel.

its worth to check the rail pressure like ive said before, maybe its receiving wrong press info from the sensor

cheers
tomalamix
F1 Driver
 
Posts: 1726
Joined: Thu Jun 03, 2010 3:15 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby davelowe » Tue Jul 31, 2012 10:32 pm

I would be tempted to try and remove any supply side problems from the equation here. Half fill a litre container with known good diesel and use a known good pipe, and immerse the pump input line. Direct the return into the same container and try that...

This problem must be solved somehow. I would guess, mind, that you either have a hole in the fuel lines, or that the pump is kaput.

There is no good reason why pipes should pop off - it is unheard of.
Silver 08 plate 5dr 1.5dci Dynamique 106 Tech Run (re-mapped)

Red 03 plate 5dr 1.9 Dynamique dci120

Best advice for Megane owners: sell it before it bankrupts you!
davelowe
Driving Legend
 
Posts: 3140
Joined: Thu May 10, 2007 3:40 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby the_toilet » Wed Aug 01, 2012 3:09 pm

i love that idea of using a can of fuel... thats cool, i will go buy some fuel lin feom somewhere...

nice one guys, i would love to get this solved... i am going to try and tow the car back to my house and tinker with it there so i can at least play... i will get a sterlisied 2-litre bottle maybe, and put diesel in there and use it for this test...
the_toilet
 
Posts: 10
Joined: Thu Jun 28, 2012 8:12 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby AlexB » Wed Aug 01, 2012 4:37 pm

It looks very much like a blocked Venturi on the HP pump. This can be caused by contamination due to incompetent repairs. I have no idea about the original problem, as the pipes did not blow straight away.

Sort out the blockage, then record the live OBD parameters while starting the engine or, at least, during an attempt to start it.


the_toilet wrote:The current problem i think is an odd pressure build up on the diesel-return pipes. The pipe blew off injector 4 (or 1, no sure where they start from) a few times, and also the pipe where fuel return goes into the top of the fuel pump, before being sent back to the fuel filter... any ideas?
AlexB
(no, a different AlexB)
AlexB
Driving Legend
 
Posts: 3831
Joined: Tue Mar 22, 2005 8:17 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby davelowe » Wed Aug 01, 2012 10:16 pm

Let us know how you get on with this. Cheers!
Silver 08 plate 5dr 1.5dci Dynamique 106 Tech Run (re-mapped)

Red 03 plate 5dr 1.9 Dynamique dci120

Best advice for Megane owners: sell it before it bankrupts you!
davelowe
Driving Legend
 
Posts: 3140
Joined: Thu May 10, 2007 3:40 pm

Re: megane DCi 1.5 - will not start - Injection fault

Postby the_toilet » Thu Aug 02, 2012 6:42 am

i definitely will guys.... and thanks
the_toilet
 
Posts: 10
Joined: Thu Jun 28, 2012 8:12 pm

Next

Return to Problems

Who is online

Users browsing this forum: Google Adsense [Bot], tomsa and 7 guests